Install and Uninstall

Install and Uninstall

Contents:

Installing

To install gsqlcmd, unzip the downloaded gsqlcmd package and run setup.exe.

gsqlcmd requires .NET Framework 4.6.2. The setup.exe prompts to install it from the Microsoft website if it is not installed.

Log off and log on to activate the PATH environment variable.

To test the installation, run in the command prompt:

gsqlcmd

By default, gsqlcmd activates a free edition. Test it first.

Try examples from the downloaded gsqlcmd package.

To activate the trial version or the purchased license, run:

gsqlcmd register

Updating

To update gsqlcmd, unzip the downloaded gsqlcmd package and run setup.exe.

Uninstalling

To uninstall gsqlcmd, open Control Panel, Programs and Features, then select gsqlcmd and click the Uninstall button.

System Requirements

Supported operating systems:

  • Windows 7, 8, 8.1, 10
  • Windows Server 2008 R2 SP1, 2012, 2012 R2, 2016, 2019

Required .NET Framework:

  • Microsoft .NET Framework 4.6.2 or higher

Supported architectures:

  • x86, x64

Supported versions of Microsoft SQL Server:

  • Microsoft SQL Server 2005, 2008, 2008 R2, 2012, 2014, 2016, 2017, 2019
  • Azure SQL Database
  • Azure SQL Data Warehouse

Supported versions of Oracle Database:

  • Oracle Database 10g R1/R2, 11g R1/R2, 12c R1, 18c

Supported versions of IBM DB2:

  • IBM DB2 9.5-9.8, 10.1, 10.5, 11.1

Supported versions of MySQL:

  • MySQL 5.5-5.7, 8.0

Supported versions of SkySQL MariaDB:

  • MariaDB 5.5, 10.0-10.4

Supported versions of PostgreSQL:

  • PostgreSQL 8.0-8.4, 9.0-9.6, 10, 11

Supported versions of NuoDB:

  • NuoDB 2.0-2.6, 3.0

Supported versions of Snowflake:

  • Latest

Supported versions of Microsoft SQL Server Compact:

  • Microsoft SQL Server Compact 3.5, 4.0

Supported versions of SQLite:

  • SQLite 2, 3
This website is using cookies. By continuing to browse, you give us your consent to our use of cookies as explained in our Cookie Policy.